netbook-launcher should automount drives

Bug #322466 reported by Bill Filler
4
Affects Status Importance Assigned to Milestone
Ubuntu Netbook Remix Launcher
Won't Fix
Medium
Neil J. Patel
netbook-launcher (Ubuntu)
Fix Released
Medium
Neil J. Patel

Bug Description

gnome-volume-manager will no longer be started in Jaunty UNR images to do automounting. netbook-launcher should implement automounting of drives when they are inserted.

Currently the launcher will correctly show the drive in the right-hand pane, but you must click on it once in order to mount it.

Tags: ubuntu-unr
Bill Filler (bfiller)
description: updated
Changed in netbook-remix-launcher:
assignee: nobody → njpatel
importance: Undecided → Medium
milestone: none → 1.2.0
status: New → Confirmed
Revision history for this message
Neil J. Patel (njpatel) wrote :

Automount plugged in devices if nautilus is not already running

Changed in netbook-remix-launcher:
status: Confirmed → Fix Committed
Changed in netbook-launcher:
status: New → Fix Committed
Neil J. Patel (njpatel)
Changed in netbook-launcher:
status: Fix Committed → Fix Released
Revision history for this message
Rachel Greenham (rachel-strangenoises) wrote :

I hate this! :-)

Specifically, my situation is that my netbook's hard drive has three partitions two of which are not normally in use, being alternate installations. I don't want them to automount, so normally they lie dormant.

Since the latest update, when netbook-launcher is launched, I immediately get two nautilus windows opened as well, when each of those partitions are automounted. I just confirmed that this is netbook-launcher doing it and not something else during boot/login because some other bug just caused netbook-launcher to die, and it happened again when I manually relaunched it.

Can this behaviour be restricted to actual removable media please? :-)

Revision history for this message
Rachel Greenham (rachel-strangenoises) wrote :

(Might be worth noting that for some reason the two partitions in question show up in netbook-launcher and in Nautilus with USB drive icons. Clearly they're not. (Internal SATA drive.) So presumably something in Linux at some lower level you're probably not responsible for is misrepresenting them. :-(

Revision history for this message
Neil J. Patel (njpatel) wrote :

The drives showing up with the wrong icon does sound a bit weird, but I've also come across it on a couple of devices. It's probably a HAL thing.

The automounting of the hard-drives is wrong, and the latest version of netbook-launcher should fix it :). Currently building in the PPA, so should make it's way down sometime today.

Revision history for this message
Mathew Hennessy (ubuntu-unixslave) wrote :

Please make this a preference.. Whenever I return from suspend/hibernate a Nautilus window with my SD card pops up. I HATE THIS, and would like to disable it please!!

I've disabled the Nautilus and GVM automount prefs, please at least add an automount pref in gconf or some way to black/whitelist the netbook-launcher behavior...

Revision history for this message
Paul Larson (pwlars) wrote :

This bug has been moved to Ubuntu distribution

Changed in netbook-launcher (Ubuntu):
assignee: nobody → Neil J. Patel (njpatel)
importance: Undecided → Medium
Changed in netbook-remix-launcher:
status: Fix Committed → Won't Fix
Paul Larson (pwlars)
tags: added: ubuntu-unr
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.