UI should show all system information fields

Bug #1883337 reported by Lee Trager
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Triaged
Medium
Unassigned
maas-ui
Triaged
Medium
Unassigned

Bug Description

In LP:1881916 a user mentioned that they are creating commissioning scripts which run on a particular SKU. When MAAS migrated to gathering system information from LXD I realized we already gather the SKU as well as other information. This information appears on the API but not the UI.

Missing fields in the UI:
system_uuid
system_family
system_sku
mainboard_serial
mainboard_version
mainboard_firmware_vendor
chassis_vendor
chasis_type
chassis_serial
chassis_version

Changed in maas:
status: New → Triaged
importance: Undecided → Medium
Revision history for this message
Caleb Ellis (caleb-ellis) wrote :

The hardware info card on machine details should probably get redesigned (or re-UXed) in that case.

I don't think we realised that the node metadata that gets sent through the websocket had dynamic keys, so a better approach might be to mimic exactly what's available on the API instead of showing a static list of metadata that may or may not exist on the API.

Changed in maas-ui:
status: Unknown → New
Revision history for this message
Thorsten Merten (thorsten-merten) wrote :

imported from: https://github.com/canonical/maas-ui/issues/1284

Needs UX review, also we need to check if we really need to know this information. This is more of a feature request.

Changed in maas-ui:
status: New → Triaged
importance: Unknown → Medium
Changed in maas:
milestone: none → 3.5.0
Changed in maas-ui:
milestone: none → 3.5.0
tags: removed: ui
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.