Ironic auto cleaning returns neutron error

Bug #1883482 reported by amirhossein moezzi
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack

Bug Description

Version: Rocky
Distro: CentOS7

I'm using Horizon but it returns the same error when I tried cli as well.
when I change state to available I expect an auto cleaning to happen but it gives me this error:
State: manageable > available

Failed to prepare node a2f9c31d-9a81-424f-9c60-90089a91a428 for cleaning: Failed to create neutron ports for any PXE enabled port on node a2f9c31d-9a81-424f-9c60-90089a91a428.

Also the same cluster returns this error when I try changing state from manageable to active:
State: manageable > active

Error while attempting to adopt node a2f9c31d-9a81-424f-9c60-90089a91a428: No VIFs found for node a2f9c31d-9a81-424f-9c60-90089a91a428 when attempting to update DHCP BOOT options..

Revision history for this message
amirhossein moezzi (amirhosseinmoezzi) wrote :

We have both ironic-api and ironic-conductor installed on the same host along with nova-compute

tags: added: openstack-ironic
description: updated
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.