can't switch back to netbook mode

Bug #460005 reported by Stephen Warren
This bug affects 1 person
Affects Status Importance Assigned to Milestone

Bug Description

I installed Jaunty UNR a while back, then just upgraded to Karmic RC last night, using "update-manager -d" as described at

Starting out in netbook mode, I can switch to classic mode. Note that the netbook launcher remains running after this, as mentioned in my recent comment to bug 322465.

Once in classic mode, I launch desktop-switcher again. The first bug is that of the two options presented (netbook, classic), netbook is initially selected, even though the current mode is classic.

The second bug is that when I select netbook mode (either do nothing and rely on initial selection, click the netbook option, or click the classic option and then click the netboook option) and then click apply, it does not correctly switch back to netbook mode. I have seen either a) Nothing at all happen, or b) Just once, the classic menu bars were all killed, the netbook launcher was displayed (although I don't recall if it was restarted, or simply left over from before due to bug 322465), and no menu bars were re-created, so no "tray" icons, no ubuntu icon to jump back to the launcher etc.

Revision history for this message
Stephen Warren (srwarren) wrote :

BTW, I find that in classic mode, both maximus and netbook-launcher are still running, and if I kill either, they auto-restart.

Revision history for this message
Stephen Warren (srwarren) wrote :

I just rebooted, and logged in to classic mode; I guess that's what I was in most recently before rebooting.

Now, starting desktop-switcher did have classic mode initially selected as expected, and clicking netbook mode then apply does do something. Specifically, the color theme changed to the black-based theme, windows started being forced maximized without decorations. However, other things didn't switch correctly: The panel at the bottom of the screen that contains icons for running applications went away, but the space is still allocated for it; a panel-sized unusable black area is now present there. Also, the top panel that contains menu bars, notification icons etc. in classic mode appears to be there still, containing Applications, Places and System menus that work, plus the "quick launch" icons for firefox etc., plus a person icon in the top-right that allows logout/switch-user. Missing are clock, network-manager status ucon, power status icon, etc.

So, still not remotely working as expected.

David Barth (dbarth)
Changed in desktop-switcher:
importance: Undecided → Medium
status: New → Triaged
Revision history for this message
Jeff Stenhouse (ishiyakazuo) wrote :

Having installed the Netbook Remix (of Jaunty) and upgrading to Karmic, I ran into the same problem. When trying to figure out how to restore the clock, etc., I happened upon this little tip:
By doing this, even though I was in "Classic" mode (without clock or other status icons), it went back to Netbook mode with all icons present.
(It's not exactly a fix, but it is a handy workaround for the problem.)

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.