Comment 13 for bug 97715

Revision history for this message
Karl Fogel (kfogel) wrote :

Some results:

[I just realized that everything below is with 1.9 format, because that's what the repository I'm testing uses. I should retry with --1.12-preview, right? Would that make a big difference?]

I'm using the Emacs repository for testing. Using bzr built from your branch above, I ran

  $ bzr branch bzr://
  $ cd master
  ### lisp/ is a subdir with lots of changes under it, let's try that:
  $ time bzr log lisp > lisp-log.out
  ### wait... wait... wait... feels like long time... ###

Hmmm. I opened up lisp-log.out and looked at the tail of the file. It is not hung -- new changes do appear -- but it's going pretty slowly. After about eighteen minutes, the end of the file has this change:

   revno: 89414
   committer: Jay Belanger <email address hidden>
   timestamp: Sun 2008-07-13 05:42:31 +0000
     *** empty log message ***

So it's only in the middle of 2008 (Emacs history go back to 1985, with about 94000 revisions).

I killed it and tried again, this time with -v so I could easily verify that it was only getting changes that affected something under lisp/. It ran at about the same speed (not surprising, when I think about likely implementation). I killed it after 8 minutes.

As far as correctness goes, it's passing all my tests so far. I have some old 'bzr log -v' for the same tree sitting around. It only goes to about November 2002 (I had to kill the process eventually), but checking those two ranges against each other in the old and new logs doesn't raise any problems. They're different, obviously, since the second one was on a subdir, but they're different in the expected ways.

I also tried plain 'bzr log -v' with your branch bzr. It seems to be running at about the same speed as 'bzr log SUBDIR' and 'bzr log -v SUBDIR'. I can't tell yet if it's any faster than it used to be.