[i855] GPU lockup 350340cf (IPEHR: 0x02000004)

Bug #721883 reported by Jim Brumbaugh
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)

Bug Description

I'm running 32 bit on a Dell Latitude with a i855 Intel video chipset (affected by graphics bug- I can finally log in!)
I have forced X11 to use the Intel driver rather than the "fbdev" driver. (I finally have OpenGL!)
I have logged in with Ubuntu "Classic Mode (no effect)"
(this would otherwise look almost normal)
I have enabled MetaCity gnome composting (now the screen is full of artifacts)
Will have to switch back to the fbdev driver for graphics stability.

Without the gnome composting very few minor artifacts up in the Gnome Panel (but still there)
WITH gnome composting, very many artifacts.
With the new clutter desktop, MAJOR MAJOR screen artifacting (extends to windows and contents.

Getting there guys! My Laptop has been unbootable ever since 10.04 due to the Intel graphics bug interacting with Plymouth.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: xserver-xorg-video-intel 2:2.14.0-1ubuntu9
ProcVersionSignature: Ubuntu 2.6.38-4.31-generic 2.6.38-rc5
Uname: Linux 2.6.38-4-generic i686
Architecture: i386
Chipset: i855
 status: connected
 enabled: enabled
 dpms: On
 modes: 1024x768
 status: disconnected
 enabled: disabled
 dpms: Off
Date: Sat Feb 19 11:00:30 2011
DistUpgraded: Yes, recently upgraded Log time: 2011-01-26 08:43:16.562841
DistroCodename: natty
DistroVariant: ubuntu
DumpSignature: 350340cf (IPEHR: 0x02000004)
ExecutablePath: /usr/share/apport/apport-gpu-error-intel.py
 Intel Corporation 82852/855GM Integrated Graphics Device [8086:3582] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Dell Latitude X300 [1028:014f]
   Subsystem: Dell Latitude X300 [1028:014f]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20101202)
InterpreterPath: /usr/bin/python2.7
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 002: ID 413c:9001 Dell Computer Corp.
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Dell Computer Corporation Latitude X300
 Socket 0:
   no product info available
 Socket 1:
   no product info available
 Socket 0:
   no card
 Socket 1:
   no card
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gpu-error-intel.py

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-4-generic root=UUID=26c46887-b3d6-4045-8a05-854afbb7e1c5 ro quiet splash vt.handoff=7
ProcKernelCmdLine_: BOOT_IMAGE=/boot/vmlinuz-2.6.38-4-generic root=UUID=26c46887-b3d6-4045-8a05-854afbb7e1c5 ro quiet splash vt.handoff=7
 xserver-xorg 1:7.6~3ubuntu6
 libdrm2 2.4.23-1ubuntu3
 xserver-xorg-video-intel 2:2.14.0-1ubuntu9
SourcePackage: xserver-xorg-video-intel
Title: [i855] GPU lockup 350340cf (IPEHR: 0x02000004)

dmi.bios.date: 11/07/2005
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: A10
dmi.board.name: 0X0213
dmi.board.vendor: Dell Computer Corporation
dmi.board.version: X06
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Computer Corporation
dmi.chassis.version: 00h
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrA10:bd11/07/2005:svnDellComputerCorporation:pnLatitudeX300:pvrA10:rvnDellComputerCorporation:rn0X0213:rvrX06:cvnDellComputerCorporation:ct8:cvr00h:
dmi.product.name: Latitude X300
dmi.product.version: A10
dmi.sys.vendor: Dell Computer Corporation
version.compiz: compiz 1:
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1~git20110215.cc1636b6-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu6
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-1ubuntu9
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A

00:00.0 Host bridge [0600]: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller [8086:3580] (rev 02)
     Subsystem: Dell Latitude X300 [1028:014f]
00:02.0 VGA compatible controller [0300]: Intel Corporation 82852/855GM Integrated Graphics Device [8086:3582] (rev 02) (prog-if 00 [VGA controller])
     Subsystem: Dell Latitude X300 [1028:014f]

Revision history for this message
Jim Brumbaugh (bleumyst) wrote :
Revision history for this message
Philip Muškovac (yofel) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in xserver-xorg-video-intel.

affects: ubuntu → xserver-xorg-video-intel (Ubuntu)
bugbot (bugbot)
description: updated
Revision history for this message
Mantas Kriaučiūnas (mantas) wrote :

I have [i845] Intel 82845G - VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 01) and Ubuntu 11.04 works in fairly good performance when I force X Window system driver to intel - see attached xorg.conf file (as default Ubuntu 11.04 uses slow fbdev).
It seems Compiz doesn't work at all with 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics - Ubuntu starts in GNOME Classic session...

Revision history for this message
Mantas Kriaučiūnas (mantas) wrote :

I found more info about solutions how to fix GPU lockups on Intel i855 and i845 hardware at LP bug #541511 and bug #541492

Revision history for this message
Bryce Harrington (bryce) wrote :

Hey bleumyst,

You filed this bug report against natty, but I see it's still open and
doesn't appear to have much activity recently. So, now that oneiric
is released and stable, this may be a good point for you to upgrade
and re-test if this issue is still present there.

If it's solved in the new release and you think it's worth backporting
the fix, please indicate that. Or if having the fix in the new release
is good enough, feel free to close out the bug (or let us know and we'll
close it.)

If it's not solved, leave the bug report open. I can't promise we'll
get to it (we get way more bugs filed than we can usually get to), but
your testing and feedback can help out if and when we do.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Incomplete
Revision history for this message
bugbot (bugbot) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.