In autopilot tests, the word Emulator is confusing
Bug #1306340 reported by
Leo Arias
This bug affects 1 person
Affects | Status | Importance | Assigned to | Milestone | |
---|---|---|---|---|---|
Autopilot |
New
|
Undecided
|
Unassigned | ||
unity8 (Ubuntu) |
Fix Released
|
Undecided
|
Leo Arias |
Bug Description
As we are trying to remove the word Emulator from our vocabulary related to autopilot introspection because it can be confused with the project used to emulate an android phone in a PC. We are replacing it with the more accurate "Custom Proxy Object".
In autopilot:
- we should rename the CustomEmulatorBase, adding a deprecation message when somebody calls it by the old name.
- we should rename the emulator_base argument, adding a deprecation message too.
Related branches
lp://staging/~canonical-platform-qa/unity8/fix1306340-deprecate_emulators
- Michael Zanetti (community): Approve
- PS Jenkins bot (community): Approve (continuous-integration)
- Albert Astals Cid (community): Needs Fixing
- Brendan Donegan (community): Approve
- Sergio Cazzolato (community): Approve
-
Diff: 1265 lines (+432/-445)21 files modifiedtests/autopilot/unity8/__init__.py (+6/-2)
tests/autopilot/unity8/application_lifecycle/tests/test_application_lifecycle.py (+4/-2)
tests/autopilot/unity8/dash.py (+7/-7)
tests/autopilot/unity8/fixture_setup.py (+6/-16)
tests/autopilot/unity8/greeter/__init__.py (+42/-1)
tests/autopilot/unity8/greeter/tests/__init__.py (+2/-2)
tests/autopilot/unity8/launcher.py (+3/-3)
tests/autopilot/unity8/process_helpers.py (+2/-1)
tests/autopilot/unity8/sensors.py (+1/-1)
tests/autopilot/unity8/shell/__init__.py (+181/-2)
tests/autopilot/unity8/shell/create_interactive_notification.py (+101/-0)
tests/autopilot/unity8/shell/emulators.py (+52/-0)
tests/autopilot/unity8/shell/emulators/__init__.py (+0/-22)
tests/autopilot/unity8/shell/emulators/create_interactive_notification.py (+0/-101)
tests/autopilot/unity8/shell/emulators/greeter.py (+0/-60)
tests/autopilot/unity8/shell/emulators/main_window.py (+0/-199)
tests/autopilot/unity8/shell/tests/__init__.py (+3/-3)
tests/autopilot/unity8/shell/tests/test_helpers.py (+17/-18)
tests/autopilot/unity8/shell/tests/test_notifications.py (+1/-1)
tests/autopilot/unity8/shell/tests/test_rotation.py (+2/-2)
tests/autopilot/unity8/shell/tests/test_tutorial.py (+2/-2)
summary: |
- Rename CustomEmulatorBase to CustomProxyObjectBase + In autopilot tests, the word Emulator is confusing |
description: | updated |
Changed in unity8 (Ubuntu): | |
assignee: | nobody → Leo Arias (elopio) |
status: | New → In Progress |
To post a comment you must log in.
The argument matching the CustomProxyObject class should also be changed to from emulator_base to custom_proxy_base